hyprland-qt-support/nix/default.nix
2025-01-09 23:32:25 +02:00

43 lines
707 B
Nix

{
lib,
nix-gitignore,
stdenv,
cmake,
ninja,
qt6,
pkg-config,
hyprlang,
version ? "0",
}:
stdenv.mkDerivation {
pname = "hyprland-qt-support";
inherit version;
src = nix-gitignore.gitignoreSource [] ./..;
nativeBuildInputs = [
cmake
ninja
pkg-config
qt6.wrapQtAppsHook
];
buildInputs = [
qt6.qtbase
qt6.qtdeclarative
qt6.qtsvg
qt6.qtwayland
hyprlang
];
cmakeFlags = [
(lib.cmakeFeature "INSTALL_QML_PREFIX" qt6.qtbase.qtQmlPrefix)
];
meta = {
description = "hyprland-qt-support";
homepage = "https://github.com/hyprwm/hyprland-qt-support";
license = lib.licenses.bsd3;
platforms = lib.platforms.linux;
};
}